Welcome, Guest. Please Login.
Gravity Simulator
11/21/17 at 02:18:00
News: Registration for new users has been disabled to discourage spam. If you would like to join the forum please send me an email with your desired screen name to tony at gravitysimulator dot com.
Home Help Search Login


Pages: 1
Send Topic Print
gsim not working (Read 4723 times)
EDG
Ultimate Member
*****


oh, crumbs!!!

Posts: 611
Gender: male
gsim not working
04/14/13 at 10:40:39
 
I tried making a new gsim file using the 'new' 3.0 Alpha, and (a) nothing showed up on the screen and (b) now it's not even opening (it crashes when I try opening the program). Granted I have been out of practice and I haven't actually used the Alpha before, so I may have done something wrong.  
 
I've attached the file, can anyone tell me what's wrong with it so I can fix it?
Back to top
 

(formerly known as Mal)
View Profile WWW   IP Logged
Tony
YaBB Administrator
*****




Posts: 1051
Gender: male
Re: gsim not working
Reply #1 - 04/14/13 at 15:30:40
 
There's something corrupt with your file, and since you likely closed gravity simulator while running this file, it is now your "resume.gsim" file, preventing the program from starting.
 
Open a folder where you store .gsim files.  Copy one that you know works.  Paste it into the same folder as the alpha 3  executable file.  Rename it to resume.gsim.  The program should then open.
Back to top
 
 
Email View Profile WWW   IP Logged
EDG
Ultimate Member
*****


oh, crumbs!!!

Posts: 611
Gender: male
Re: gsim not working
Reply #2 - 04/14/13 at 16:24:19
 
Yeah, I did that and eventually got something working again... but can I salvage the file I attached? Or do I just have to go back and make it all over again?
Back to top
 
 

(formerly known as Mal)
View Profile WWW   IP Logged
Tony
YaBB Administrator
*****




Posts: 1051
Gender: male
Re: gsim not working
Reply #3 - 04/15/13 at 09:31:44
 
You might be able to salvage it in a text word processor, if you know what all the code means.  Most possible explanation is the number of objects does agree with the actual number of objects.  I'll look at it later.
Back to top
 
 
Email View Profile WWW   IP Logged
frankuitaalst
Ultimate Member
*****


Great site

Posts: 1507
Gender: male
Re: gsim not working
Reply #4 - 04/15/13 at 12:01:32
 
When  I open Mal's file I get a lot of "#QNAN" where actually positions and velocities should be .  I'm afraid the file is corrupt .
Back to top
 
 
Email View Profile   IP Logged
EDG
Ultimate Member
*****


oh, crumbs!!!

Posts: 611
Gender: male
Re: gsim not working
Reply #5 - 04/15/13 at 18:23:47
 
Quote from frankuitaalst on 04/15/13 at 12:01:32:
When  I open Mal's file I get a lot of "#QNAN" where actually positions and velocities should be .  I'm afraid the file is corrupt .

 
Oh, is that what that means, I was wondering about that.  
 
Sigh. OK, back to the drawing board then...
Back to top
 
 

(formerly known as Mal)
View Profile WWW   IP Logged
Tony
YaBB Administrator
*****




Posts: 1051
Gender: male
Re: gsim not working
Reply #6 - 04/15/13 at 20:25:25
 
yeah, sorry.  there's no way I can recover it without the r & v's  cry
Back to top
 
 
Email View Profile WWW   IP Logged
EDG
Ultimate Member
*****


oh, crumbs!!!

Posts: 611
Gender: male
Re: gsim not working
Reply #7 - 04/16/13 at 08:07:33
 
The weird thing is that as far as I know I didn't do anything to corrupt the file. I just made the system, it didn't show up, then I closed the program and  tried to reopen it and it wouldn't work.
Back to top
 
 

(formerly known as Mal)
View Profile WWW   IP Logged
frankuitaalst
Ultimate Member
*****


Great site

Posts: 1507
Gender: male
Re: gsim not working
Reply #8 - 04/16/13 at 12:24:08
 
I'm not sure Mal , but my best guess is something happened at the input of your bodies . In C++ the Qnan stands for "not a number " . I also notice in the file  the value "#INF" , which probably is an infinite value . It may be possible you've tried to input a character instead of a value , which confused GravSim . Not sure as I said . Maybe Tony can explain how inappropriate input values are handled n the input section .  
I remember I once had  ,  a long while ago , a problem inputting values resulting in GravSim not starting . AFAIR I had problems choosing the decimal point versus comma .
Back to top
 
 
Email View Profile   IP Logged
Pages: 1
Send Topic Print